Mac 5 Creative

Your Partner in Customer Communications

“Awwww, do I hafta update my WordPress?”

Posted on Sep 23, 2019 in Featured

The answer is “yes and no.” Like any software application WordPress is subject to relatively frequent updates and it’s important to update WordPress, its plugins, and themes. Good news is that we at Mac 5 Creative will take care of this for you so that is where the “no” part of the answer comes into play.  Why should I have Mac 5 Creative do this? Because updating WordPress and its plugins will:

Fix bugs Like any app, WordPress and the plugins used with it can periodically suffer from bugs popping up in the code. Updating the WordPress core, plugins, and themes will fix annoying bugs discovered in the previous version. Nobody likes bugs – they can diminish website functionality, making it unreliable and just plain difficult to work with.

Add functionality and features This one’s pretty obvious. Who doesn’t want the latest bells and whistles to make their website look great and attract more visitors? Go ahead and update. You know you want all that good stuff.  One of the features that have been improved upon is the content editor that you use to write your pages and posts by improving capabilities or adding shortcuts for frequently used formatting.

Increase your site security Another no-brainer. With all the stories in the news about serious hack attacks stealing information and shutting websites down, why risk it? When Internet experts talk about web security, the first thing they say is “install updates.” The second hackers see notices about system vulnerabilities, they pounce to take advantage of people too busy and uninformed to make the necessary upgrades and close the gaps. According to a recent study, 83 percent of hacked WordPress websites hadn’t been updated.

Allowing the experts at Mac 5 Creative to update your WordPress site will allow us to make sure your site stays working the way it was before the update.  Sometimes plugins and themes are customized that if updated could break that custom functionality.  It is also hard to know when customizations have been done to these files. There are precautions we take to ensure the update does not remove any of the functionality that makes your site great.

Want to hear something even scarier? The FBI recently issued a warning that ISIS/ISIL(!) sympathizers are using WordPress plugin vulnerabilities to deface and damage websites. If you’re thinking “that can’t happen here,” just remember recent homegrown terrorist attacks that occurred in low-profile places. Lone wolf sympathizers sitting in any American city or town are just as likely – perhaps even more so – to attack local targets as high-profile, national ones.

All-In-One SEO Pack is one of the most downloaded WordPress SEO plugins, making it an attractive target for hackers looking for soft spots to exploit. Are you using All-In-One? Has it been updated recently? No? As recently as a few months ago there was a vulnerability found that allows hackers access to your site.  By updating this plugin to the latest version it closed up this security hole in the system.

As much as we would love to think that a website is a “set it and forget it” tool it is not. Not only do you need to make sure the content is being updated but you also need to make sure the software is updated and kept updated. Let Mac 5 Creative handle that piece of your website.  Included with our premium hosting packages we will monitor and update your WordPress site as needed.  So drop us an email or give us a call as we are here to help.